Trying to upload FTDNA matches file into rootsfinder

Hi all,

Hello, thank you for accepting me. I tried to upload my ftdna familyfinder data onto rootsfinder having downloaded the files with dnagedcom. When I try to put the file into choose file it appears next to the box, not in the box and nothing happens. What am I doing wrong? IN83740_Family_Finder_Matches.csv.
Stella Ellis

I’m not sure what’s going on. Here’s a short video where I tried to show how it should work.

In the video, I clicked on “Choose file”, then selected a file, and as soon as the file was selected and appeared to the right of “Choose file”, a dialog opened asking me to choose a min and max range. If that doesn’t happen for you, please right-click somewhere on the page, then select “Inspect” from the menu that opens, then select the “Console” tab, and you should see some red text indicating the type of error that occurred. If you would copy that text here, I can figure out what’s going on. Also, if you’re comfortable emailing me your family finder matches.csv file (dallan@rootsfinder.com), that could also help. I’m sorry it’s not working.