Tree (database?) won't open

Well here’s a first (at least as far as I can recall): my tree will not open.

It’s very strange, because I can open my list of sources OK, and I can open items within that list. However, if I try to open my tree itself in another tab, I just get the darkened overlay and the “Please wait…” message. It’s been there for a good 10 minutes, so I don’t think it’s going anywhere.

I tried clearing my browser cache & cookies, same result. I can load other web pages no problem.

When I re-logged into rootsfinder, it took me first to my dashboard. I noticed that the little box on the upper right with the icon-coded statistics looked funny. All the numbers were zeroes except for the media, notes, and hints icons. People, stories, and evidences are all zero, which ain’t right. :frowning:

MacOS Big Sur 11.7
Firefox 104.0.2 (64-bit)
Also tried Safari Version 16.0 (16614., 16614) – same result

Update, I tried it now an hour or two later and it worked. So cancel the red alert, I guess.

What could cause this temporary malfunction?

The icons showing up funny can be caused by one of two things:

  1. there is an ad-block plugin that is blocking the icons from getting loaded by google, or
  2. there is a temporary network outage.

The tree not showing up is really odd though, because your entire tree is downloaded into your browser when you first open it, so we don’t need to download the people again when you navigate to your tree. It does make a few small network requests though when you navigate to your tree, so maybe a temporary network outage could cause it?

The other possibility is that the RootsFinder server itself went down for a while. I have two servers set up so that if one goes down the other takes over until a new server comes up to take its place, but there’s a load-balancer (from AWS) that forwards the requests to the servers, and if that were to go down temporarily, then that could have caused the problems you were seeing.