PDF thumbnails 'fixed' but still not generating?

Previously reported as Have the PDF thumbnails stopped working?

Existing broken ones were fixed but just added 2 page PDF to this person and no thumbnail generated. https://www.rootsfinder.com/tree/58863/people/0TP-P7AB-WT9P

That’s looks like one of those PDF thumbnails that doesn’t get generated for some strange reason. I see the error from the thumbnail generator I use in the logs, and after trying unsuccessfully to create the thumbnails, it returns an error “contains no images”, which doesn’t make sense. One potential issue is even though this is just a 2 page PDF, the pages are quite large: 11372 x 13961 pixels each. Large PDFs have caused trouble in the past.

I just tried uploading another PDF, and the thumbnails generated ok on that one. I think the problem with this one may be the old “sometimes PDF thumbnails don’t generate”.

Strange. I’ve tried reducing the file and get the same result. I’ll just give up and post 2 x jpgs but it is a bit frustrating :slight_smile:

Oops apologies - the reduced file did work, just took a while. Thanks for the guidance.

In the future I need to find a better solution for PDF thumbnail generation. The thumbnail generator spent a full 10 minutes trying to generate a thumbnail for the original large PDF before throwing the error, and I’ve seen successful thumbnails take minutes. It shouldn’t take that long to generate a thumbnail. :slight_smile:

Interesting. Seems odd that it had to work so hard but at least I can look at workarounds. Just makes it a bit hard to tell the difference between not working at all or not working for this pdf.