Imported GEDCOM not showing in existing tab


Apologies if this is already known.

I imported a GEDCOM into a new tree, and left the tab open. The notification to advise it was completed showed okay, but the page will not refresh to show the new Tree content no matter which links on the Tree page I click.

I opened the email notification and clicked the link from there, which worked. I can see the tree contents in the new tab.

Both URLs are the same however the original (not working) tab is a previously pinned tab.

I’m on a vanilla Win8 machine using Chrome [55.0.2883.87 m]. I’m not on my work machine so don’t have Fiddler or anything installed but would be happy to set this up if required. Hoping this is just a session issue and nothing major.

A Ctrl-f5 on the original tab fixed it.


  • Paula

To answer my own question - the second GEDCOM I just imported worked fine within the previously pinned tab, using just the browser refresh button.

I will leave the Pinned tab overnight and re-try again, I am fairly sure it was something screwy with my window session state and nothing to do with the site.

Thanks for letting me know. I’ve seen this problem occasionally in the past but I thought i had fixed it. I must not have. I’ll look into it on Monday. I’m pretty sure it’s due to a race condition, which is why it happens only occasionally.

i re-worked the logic around accepting a completed gedcom import. Hopefully the problem has been fixed for good this time.

1 Like