Import GED - doesn't show middle names

When I import a GEDCOM it doesn’t show the middle names - only Christian and Surname appear in the tree and profile header.

Is this a problem with the GED from MacFamilyTree or is this the same with all GED imports? I have checked the format of the GED file and the middle names are all there but appear as an extra Name entry further down the profile - with the GED tag SECG. Here is an extract from a GED file showing my grandfather’s full name : Charles William Henry Mees :

1 NAME Charles William Henry /Mees/
2 GIVN Charles
2 SURN Mees
2 SECG William Henry

In Charles Mees profile it shows:

Charles Mees - Supporting Evidence - SECG: William Henry

I have eight Charles Mees in my tree and it would be really useful to show the full name in the tree and at the top of the Profile rather than having to check dates to see if I have the correct Charles Mees.

This appears to be the same when I import the GED file to MyHeritage and I then get loads of hints with middle names from FamilySearch.

However Ancestry imports the full name including middle names and shows it in the tree.

As an experiment I imported my GEDCOM with the default MacFamilyTree settings to Ancestry and middle names are shown in the tree.

I then exported the GEDCOM from Ancestry and imported it as a Test tree to Rootsfinder and I now have a tree with all the middle names. However that workaround will not allow me to import all my Source files from MacFamilyTree.

What is the best format for import to Rootsfinder? I use the default UTF-8 / macOS line feed

MacFamilyTree has 5 different format options for export GEDCOM -

  • UTF-8
  • UTF-16
  • MAC OS Roman
  • Windows

And 3 different line feed options

  • MacOS
  • Windows
  • Unix

I’ve tried exporting Windows format / Windows linefeed and importing that to Rootsfinder but it still doesn’t show the middle names in the tree.

Any thoughts?


In my experience middle names show up because they have been entered after the first name but within the first name field, i.e. the data schema at ancestry does not offer a blank for middle names in their data entry forms.

Thanks Jenny - Ancestry imports my GEDCOM file and places the extra middle name field in the correct place after the first Christian name. If I export the Ancestry tree and import to Rootsfinder or MyHeritage the entries have the middle names.

I wonder could Rootsfinder import the SECG field in the same way that Ancestry imports it.


The problem as you’ve identified it is the SECG field. It’s not standard GEDCOM, and I haven’t seen it exported from other programs.

I’m going to mark this as a bug, because I agree the work-around is less than ideal. I’ll try to get it fixed this weekend.

UTF-8 and MacOS line endings is the best output format.

1 Like

Thanks Dallan as always.

I did check the GEDCOM standard and couldn’t see the field name. I think I will ask MacFamilyTree - Synium Software - why they use it since it is not in the GEDCOM standard and is incompatible with transfer of data to other systems.

In the meantime if you can fix it by adding the Middle name(s) to the First Name that would be very helpful.

I also have a query with MyHeritage asking them if they could do the same as Ancestry and accept the Middle Names.


Should have read more carefully I was thinking about GEDs from other platforms especially Ancestry not passing middle names as discrete data. DNA users have a real challenge keeping multiple trees across platforms

1 Like

RootsFinder handles the SECG field now :slight_smile:

It would be a good idea to ask Mac Family Tree to put the middle names in the GIVN field, or at least to make it possible as an option, since that’s the standard.

I have informed MacFamilyTree and they say they were aware of the problem this causes and aim to fix in the next release.

Thanks again

Allan Mees