Evidences: You can't fix what you can't see


I previously removed the source from three evidences that I could see, with the intention of deleting it thereafter. Apparently, though, it’s still attached to something?

If you need to go into my sources to investigate it, this is the source called Civil War ‘Widow’s Pensions’.

(Incidentally, I think this has happened to me at least one other time before, but I didn’t make a note of what the un-deleteable source is.)

This may be related to the blank sources issue. I’ll look into it later this week along with the other issue. Thank-you for letting me know.

This should be working now (finally).

1 Like

This is great, Dallan! Huge improvement. I was working on my tree yesterday, and at one point I refreshed the sources list and saw that all the blank rows were gone, and I thought “Wow, look at that, he solved it!”

The one unanticipated side effect in my sources is pictured here:

The good news is that many of those “Media:” items were unattached to any evidences, so I could delete them. That still leaves me with quite a few of them, but at least I can see what evidences they’re attached to.

For example, I opened that first one, “Media: database and images REGI: 1880 U.S. census PLAC: Washington County, Indiana…” It was attached to an 1880 census event for a family of my relatives in that county, and on their profile pages the event source showed up as “Supporting Evidence.” The correctly formatted source for them was also in my sources, though, so it wasn’t too hard to assign that to the event, delete the “Supporting Evidence” source, and then go back and delete the corresponding “Media:” item out of my sources.

So I guess those “Media:” source items are garbled reiterations of other properly-formatted sources in my database? Not sure if this is an issue needing an urgent fix, since the overall issue has been effectively addressed. Assuming these garbled sources aren’t something you could just eliminate with a few keystrokes, I’m okay with fixing them one by one myself, since Rootsfinder has more important development issues to be worked on.

To elucidate the related (or remaining?) issue I mentioned in my previous post: what I’ve found is that I have a number of Evidences which are connected to a source, but not to an individual. In my old database these were text notes with source citations included as footnotes; when I converted that db into a GEDCOM and imported it here, Rootsfinder seems to have not known what to do with them.

This is what they look like in my Evidences list:

When I click on one to open it up, I see this:

When I click on the trash can icon to try to delete it:

“Okay,” I think, “I should attach it to the person, and then I’ll be able to delete it.” But when I try to do that…

Hope this is helpful.

Ok, I figured out what’s going on, but I’m going to need your help to figure out how best to fix it.

When we imported your GEDCOM, your GEDCOM had source-citations on some of the notes. Our data model doesn’t support source-citations on notes, so we converted the notes to evidences. But we neglected to create the (non-specific source) facts that should have linked the evidences to the people the notes were originally attached to.

So now we have a set of evidences that are attached to people, but the people aren’t attached to the evidences. (It’s a bit more complicated than that, but not much.) The net effect is what you saw: you get errors when you try to delete the evidence (because the evidence is attached to a person), and also an error when you try to attach the evidence to a person (because it’s already attached to a person).

I’m going to fix this for future GEDCOM uploads, but for your GEDCOM there are three things we can do:

  1. I can squelch the error so you can delete the evidences.

  2. I can delete all evidences like this that are attached to people but where the people aren’t attached to them. This is my least-favorite option because it means possibly deleting things you might have wanted to keep.

  3. I can add facts to attach the evidences to the correct people. This is more work, but it’s the correct thing to do.

1 Like

Option 3 would be great, but I know you have a lot to do and I hesitate to choose something that might take a while to get done. If it’s a matter of more than, say, a week or two before your work queue would allow you to get to this, then I’d be fine with option 1. I don’t think losing whatever information is in those evidences is a disastrous prospect, because either way I’m still going to be double-checking my old file in Reunion on my Mac to copy and paste text notes (and their sources) over into Rootsfinder.

Let me see what I can do this Saturday to fix it. If it has affected you, it may have affected others as well.

I did an investigation and this issue affects several other users, so we are going to fix it. It will likely take a week or two to correct. We want to be sure we know what we’re doing before we start machine-editing trees. But we will get the issue resolved. Thank you for bringing it to my attention!

1 Like

Ok, I finally took care of this. I’ve applied the fix to the data in my trees, my wife’s trees, and your trees. I’m going to wait a couple of weeks to make sure that I’ve made things better before I apply the fix to the other trees. If you notice any other problems deleting things, would you please let me know?

1 Like

This makes me so happy. Thanks a million, Dallan! I’ll let you know if I run into any related hiccups.

Dallan, I got all my stray sources deleted… except one. The one last single source that I can’t delete. it’s the one named “** DELETE ** Media: digital images PERI: Roster of Wisconsin Volunteers, War of the Rebellion…”

It’s the same thing as before, no profile page is linked as the evidence it is attached to.

I went to the source, and when I attempted to delete it, I saw the evidence that it was attached to. I clicked on the evidence, which took me to the evidences list. I then had to wait about 15-20 seconds for the evidences list to appear (I need to look into why it took so long), but eventually the evidence list came up and the evidence that the source was attached to displayed in a pop-up dialog. I deleted the evidence, then went back to the sources list and deleted the source. Everything seems ok. I’m not sure why the evidence didn’t show up for you, but I’m thinking it probably has to do with the evidence list taking such a long time to appear. My computer is fairly new, so it could take longer on an older machine. I’ll try to speed it up in the future.

1 Like

Thanks, as always, for your help, attention, and dedication, Dallan.

Yeah, I’d noticed that some lists, e.g. evidences, take quite a while to appear for me. As an experiment, I opened my Evidences list in another tab just now to see how long it would take. It took this long:

I took that screenshot, clicked on “Wait,” and came back to this tab—which I found to be blank. I hit refresh, and this forum post came back up, complete with what I had typed so far. Strange.

Yesterday (or was it Saturday?) when I wrote my previous post in this thread, I had tried something similar: I left the “delete source” box open pretty much indefinitely, hoping the name of the ancestor from the evidence would eventually appear (as they usually take a minute to do). I think I left that tab open in the background for about a half hour, and the name never appeared.

So… yeah, I don’t know if it’s because of my 2015 MacBook, or if it’s just that I have so many sources and evidences? Anyway, thanks again for all your help, Dallan.

Yeah, when the browser says the page is unresponsive, that’s definitely too long. I’ll look into it on Saturday.

I’ve shaved off some time on the evidences list. It’s not as much as I was hoping, but it’s as good as I can do right now.

1 Like