Creating new person on Family Search from RootsFinder sometimes fails with 'Error accessing FamilySearch'

I have had several instances of this error when trying to create a person in FS (no match found). It occurs repeatedly for that person but might not occur for other people who are created successfully (albeit often with data missing as per separate post).

The person can be succesfully created manually in FS and then matched but it is annoying to get this error.

Could you send me a url that this appears on? And don’t add that particular person? I will look into it.

Hi there

Here is the URL of an example. It has happened to me several times.

Marlene

https://www.rootsfinder.com/tree/22473/people/1QA-117A-93DA

I just tried that URL and it didn’t give me an error (unfortunately).

If it happens again, could you please: right-click somewhere on the page, select “Inspect”, then select the “Console” tab, and send me the red text in the console window? I’d really appreciate it.

The URL works, but the attempt to add the person to Family Search doesn’t work and still gives the error.

The console red text is:
api.familysearch.org/platform/tree/persons?locale=en:1 Failed to load resource: the server responded with a status of 400 ()

I am logged into Family Search and can do other tasks. Note also that when the problem occurs for one person it always happens for that person. There are other people that the (ADD) function works fine for in the same session.

PS: Just to clarify - I’m swapping between two accounts at the moment and accidentally used the other account to respond to this :slight_smile:

For what it’s worth, I get the same error whether as owner of the tree or as and invited editor.

Unfortunately, I don’t get the red text when I try to match this person, even though you do:

That’s going to make finding the problem more complicated. Can you close your rootsfinder browser tab if it’s still open, open rootsfinder in a new browser tab, and send me a the URL for a different person that matching doesn’t work on? If we’re lucky, it won’t work for me either. If we’re unlucky, then we’ll need to try something else.

What browser are you using? Maybe that’s the difference.

Just to be clear, the error doesn’t occur when trying to match the person (I get the same window as above) but does occur when you use the “NONE MATCH (ADD)” option to try to create the person. I am using Mac running most recent OS 10.13.6. The problem occurs when using three different browsers, Safari, Firefox and Chrome. Note, though, that I have been able to successfully create quite a number of people, but some people just stubbornly refuse to be created.

Here’s another URL https://www.rootsfinder.com/tree/22473/people/6A2-7255-NQEP I seem to be getting plenty of these errors at the moment.

I see. I’m sorry I misunderstood. I was able to repeat the error and fixed it this morning. Let me know if you into any other problems. FamilySearch changed their api recently; hopefully this is the last issue.

If you have a RootsFinder tab already open, you will need to refresh it to get the latest update.

Thanks so much. I was having trouble finding any that actually worked, so it is good to be working again. The persistence is much appreciated (and I will try to be clearer with steps to reproduce the problem another time).

I’m glad it’s working again! Thank you for your patience and your help finding it.